CVE-2026-115915
9.8, criticoVllm-project vllm Improper Input Validation Vulnerability
- CVSS
- 9.8, critico critica CVSS v3.1
- EPSS, prossimi 30 giorni
- 0.6% superiore al 50.1% delle CVE con punteggio
- Sfruttamento
- Nessuna prova pubblica
- Pubblicata
- 26 ott 20263 giorni fa
Descrizione
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
Dettagli
- Vendor
- Vllm-project
- Prodotto
- vllm
- Debolezza
- CWE-20 (si apre in una nuova scheda)
- Stato
- Analizzata
- Aggiornata
- 28 ott 2026
- Assegnata da
- security-advisories@github.com
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Riferimenti 4
Patch e correzioni 3
Altri riferimenti 1
Il tipo è ricavato dai tag di NVD dove ci sono, altrimenti dalla forma dell'URL: consideratelo un indizio.
Altre CVE di Vllm-project
Tutte le CVE di Vllm-project che abbiamoStesso vendor in ciò che abbiamo, non un legame noto fra le falle.
- CVE-2026-115912 Vllm-project vllm Deserialization of Untrusted Data Vulnerability EPSS 0.5% 8.8, alto
- CVE-2026-116176 Vllm-project vllm Server-Side Request Forgery Vulnerability EPSS 0.3% 8.2, alto
- CVE-2026-116177 Vllm-project vllm Uncontrolled Resource Consumption Vulnerability EPSS 0.3% 7.5, alto
- CVE-2026-116179 Vllm-project vllm Allocation of Resources Without Limits or Throttling Vulnerability EPSS 0.3% 7.5, alto
- CVE-2026-116180 vLLM from 0.8.5 before 0.31.0 has a denial of service flaw EPSS 0.2% 7.7, alto
- CVE-2026-116172 Vllm-project vllm Improper Input Validation Vulnerability EPSS 0.3% 7.5, alto
- CVE-2026-116173 Vllm-project vllm Improper Input Validation Vulnerability EPSS 0.3% 7.5, alto
- CVE-2026-116174 Vllm-project vllm Improper Input Validation Vulnerability EPSS 0.3% 7.5, alto
Oltre questa pagina
CVE-2026-115915 è nella vostra rete?
Questa pagina vi dice quanto è pericolosa CVE-2026-115915 in circolazione. Se si trova su uno dei vostri dispositivi, può dirlo solo una scansione della vostra rete. È quello che i nostri sistemi fanno ogni giorno per le aziende che proteggiamo.
-
EXYS7600 OCELOT
Trovarla prima degli attaccanti
Ocelot scansiona la vostra rete a intervalli pianificati e segnala ogni vulnerabilità che trova con il suo identificativo CVE, il punteggio CVSS e quanti dei vostri host sono interessati. Un risultato come CVE-2026-115915 arriva con i dispositivi da aggiornare.
Scoprite EXYS7600 OCELOT -
EXYS7950 KONDRA
Rilevarla se viene sfruttata
Finché la patch non è installata, Kondra sorveglia rete, eventi ed endpoint in tempo reale. Tiene l'inventario del software installato su ogni endpoint, e le sue regole di rilevamento delle anomalie segnalano cosa fa un attaccante una volta entrato.
Scoprite EXYS7950 KONDRA
Dati compilati dall'API NVD 2.0, dal catalogo CISA Known Exploited Vulnerabilities e da FIRST EPSS. I punteggi si riferiscono alla nostra ultima raccolta del 29 ott 2026, non allo stato attuale delle fonti.