CVE-2026-78162
9,8, critiqueApache Software Foundation Apache Camel Deserialization of Untrusted Data Vulnerability
- CVSS
- 9,8, critique critique CVSS v3.1
- EPSS, 30 prochains jours
- 0,9% supérieur à 60,2% des CVE notées
- Exploitation
- Aucune preuve publique
- Publiée
- 19 oct. 2026il y a 16 jours
Description
Deserialization of Untrusted Data vulnerability in Apache Camel. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The camel-hazelcast component applies a default Hazelcast JavaSerializationFilterConfig to the instances it creates from its own configuration, a protection introduced by CVE-2026-43865. That change did not reach two of the configuration paths Camel builds itself, so those paths continued to create Hazelcast instances whose Java deserialization is unrestricted. ReplicatedHazelcastAggregationRepository extends HazelcastAggregationRepository but overrides doStart() without calling super.doStart(), keeping its own copy of the bootstrap block, and therefore never received the filter: a route using it without supplying a hazelcastInstance starts a Hazelcast member that deserializes values read from the backing ReplicatedMap with no class restriction. HazelcastDefaultComponent#getOrCreateHzClientInstance() builds its own ClientConfig when hazelcastMode=client is selected and neither a referenced ClientConfig nor hazelcastConfigUri is supplied, and likewise applied no filter, so client-mode endpoints behaved differently from node-mode endpoints for an otherwise identical configuration. In both cases an attacker able to publish into the Hazelcast cluster that the affected instance is attached to can cause a serialized Java object of their choosing to be deserialized inside Hazelcast's own serialization layer, before Camel processes the exchange, resulting in remote code execution. Hazelcast clusters have neither authentication nor TLS enabled by default. Selecting client mode is a topology choice rather than a security option, so neither path required the deployment to opt in to unsafe behaviour. Users are recommended to upgrade to version 4.23.0, which fixes the issue. If users are on the 4.22.x releases stream, then they are suggested to upgrade to 4.22.1. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.5. The 4.14.x releases stream and earlier reached end of life before this issue was resolved and will not receive a fix, so deployments on those lines must move to a supported release. For deployments that cannot upgrade immediately, supply an explicit Hazelcast configuration carrying a JavaSerializationFilterConfig, or inject a pre-built HazelcastInstance, since a user-supplied configuration is never overwritten by Camel. Alternatively set the JVM-wide filter -Djdk.serialFilter=!java.net.;java.;javax.;org.apache.camel.;!* and enable Hazelcast cluster authentication and TLS to restrict who can reach the cluster.
Détails
- Éditeur
- Apache Software Foundation
- Produit
- Apache Camel
- Faiblesse
- CWE-502 (s'ouvre dans un nouvel onglet)
- Statut
- Analysée
- Mise à jour
- 3 nov. 2026
- Attribuée par
- security@apache.org
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Références 8
Correctifs 8
- camel.apache.org /security/CVE-2026-43865.html (s'ouvre dans un nouvel onglet)
- camel.apache.org /security/CVE-2026-78162.html (s'ouvre dans un nouvel onglet)
- github.com /apache/camel/pull/25566 (s'ouvre dans un nouvel onglet)
- github.com /apache/camel/pull/25595 (s'ouvre dans un nouvel onglet)
- github.com /apache/camel/pull/25599 (s'ouvre dans un nouvel onglet)
- github.com /apache/camel/pull/25600 (s'ouvre dans un nouvel onglet)
- issues.apache.org /jira/browse/CAMEL-24413 (s'ouvre dans un nouvel onglet)
- issues.apache.org /jira/browse/CAMEL-24420 (s'ouvre dans un nouvel onglet)
Le type est déduit des étiquettes de NVD lorsqu'elles existent, sinon de la forme de l'URL : considérez-le comme un indice.
Autres CVE de Apache Software Foundation
Toutes les CVE de Apache Software Foundation dans notre baseMême éditeur parmi les CVE de notre base ; cela n'implique aucun lien connu entre ces failles.
- CVE-2026-64618 Apache Software Foundation Apache Fineract SQL Injection Vulnerability EPSS 0,6% 9,8, critique
- CVE-2026-65874 Apache Software Foundation Apache Fineract SQL Injection Vulnerability EPSS 0,6% 8,8, élevé
- CVE-2026-79983 Apache Software Foundation Apache Camel Path Traversal Vulnerability EPSS 0,7% 9,1, critique
- CVE-2026-79986 Apache Software Foundation Apache Camel Path Traversal Vulnerability EPSS 0,6% 9,1, critique
- CVE-2026-92414 Apache Software Foundation Apache Jackrabbit Session Fixation Vulnerability EPSS 0,7% 9,1, critique
- CVE-2026-104714 Apache Software Foundation Apache Struts Race Condition Vulnerability EPSS 0,5% 8,8, élevé
- CVE-2026-86089 Apache Software Foundation Apache NiFi Missing Authorization Vulnerability EPSS 0,4% 7,1, élevé
- CVE-2026-87976 Apache Software Foundation Apache NiFi Registry Path Traversal Vulnerability EPSS 0,8% 8,1, élevé
Au-delà de cette page
CVE-2026-78162 est-elle présente sur votre réseau ?
Cette page vous dit à quel point CVE-2026-78162 est dangereuse de manière générale. Savoir si elle se trouve sur l'un de vos appareils, seul un scan de votre propre réseau peut le dire. C'est ce que font nos systèmes, chaque jour, pour les entreprises que nous protégeons.
-
EXYS7600 OCELOT
La trouver avant les attaquants
Ocelot analyse votre réseau de manière planifiée et signale chaque vulnérabilité trouvée avec son identifiant CVE, son score CVSS et le nombre de vos hôtes touchés. Chaque résultat, comme CVE-2026-78162, est accompagné de la liste des appareils à corriger.
Découvrir EXYS7600 OCELOT -
EXYS7950 KONDRA
La détecter si elle est exploitée
Tant que le correctif n'est pas installé, Kondra surveille le réseau, les événements et les terminaux en temps réel. Il tient l'inventaire des logiciels installés sur chaque terminal, et ses règles de détection d'anomalies signalent ce que fait un attaquant une fois dans le réseau.
Découvrir EXYS7950 KONDRA
Compilé à partir de l'API NVD 2.0, du catalogue Known Exploited Vulnerabilities de la CISA et de FIRST EPSS. Les scores correspondent à notre dernière collecte du 4 nov. 2026, pas à l'état actuel des sources.